[Resolved] Thread pages broken? No userbox, no bar, wonky reactions

#1
Miles
Edit: Resolved. Problem was the browser being out of date, apparently. Facepalm My bad.

This in Firefox 47.0.1. NoScript enabled but nothing here is blocked.

I get no userbar on forum thread pages.

[Image: iJ1e8CI.png]

^ Hitboxes are wonky. I get hover-over text and hand mouse from the post below? (Alt text is where the then-hand-shaped mouse is.) Button highlight still works correctly, though, but only that much of it does.


If I see a post I want to upvote...
[Image: k7c2YkJ.png]

I do so, and see their points go up...
[Image: 530X1BN.png]

But the number remains at whatever it was prior until I come back to the page.
[Image: jNCKnC3.png]
#2
Spritanium
Can you disable noscript (and all other plugins) just to confirm that's not the issue?
#3
Spritanium
Also the welcome box not showing up is caused by a load blocking JS error, so can you check your browser console too?
[Image: O7N9eYD.png]
[Image: Q0L8Wm2.png]  <- Help me work on MW instead of doing my job

DRAKU WAS HERE SPRITEY IS A LOSER
#4
Miles
Firefox, in safe mode (no extensions whatsoever)

Image 1, image 2

It was working for a tiny bit after you first replied (before trying anything, still had all extensions on) but then it stopped again and is still stopped. Shrug

Edit: It's very very on and off. Sometimes it's working, sometimes it ain't. Bad network route to jquery, perhaps? I dunno.
#5
Draku
try clearing your cache
[Image: ynr38c.jpg]
#6
B-man
Try turning your PC off and back on again
#7
Miles
neither of those things worked :(

I do figure this is something on my end regardless though, sorry about this, I reckon consider this resolved since it's not an actual forum bug

I still find it very strange that this stuff I spoke of in the first post only ever happened on thread pages and not ever the front page (the notification system was always working, even on the bug-time pages, weirdly enough)
#8
Beako
now i bet they're going to rename Season 1 to Season 0.5
#9
Miles
(Jan 6, 2017 at 2:33 PM)Spritanium Wrote: If you want to do some bug testing in Firefox, you can just open up your browser console (ctrl+shift+k), wait until a page fails to load properly, and copy any errors that appear.

well, it's always this, extensions or no extensions
(Jan 1, 2017 at 9:13 PM)Miles Wrote: Firefox, in safe mode (no extensions whatsoever)
Image 1, image 2
unreachable code after return statement mespeak.js:3878:1053
(continues many many times over with same error, same script, and many different line locations)

I'd normally leave this alone but Stalin told me elsewhere that he had the same issues here so Shrug might be worth checking into, might not

works perfectly fine 100% of the time in extension-having Chrome (Adblock Plus, ScriptSafe with various things allowed), so I'm content with just using that if this doesn't get anywhere
#10
Spritanium
Hmm, mespeak.js is the text-to-speech plugin used for the Outta Sight spell. It shouldn't even be doing anything unless there's an instance of that Spell on a page. I'll have to look into this
#11
Spritanium
What's interesting though is that those are just warnings, not errors, so they shouldn't keep the page from loading completely
[Image: O7N9eYD.png]
[Image: Q0L8Wm2.png]  <- Help me work on MW instead of doing my job

DRAKU WAS HERE SPRITEY IS A LOSER
#12
Draku
what i want to know is why you're using an out-of-date firefox if you're willing to have chrome on your computer

it shouldn't fix the problem, but it at least would make sense to try a more up to date version of the browser you're having issues with
[Image: ynr38c.jpg]
#13
Miles
(Jan 6, 2017 at 7:22 PM)Draku Wrote: what i want to know is why you're using an out-of-date firefox
welp, I'm a massive dumb dumb

had to update it twice (about menu only jumped it up a minor version at first?) but now everything seems good

my sincerest apologies, I reckon this is resolved for real this time
#14
Spritanium
Ahh nice. I was wondering why FF was testing fine for me
[Image: O7N9eYD.png]
[Image: Q0L8Wm2.png]  <- Help me work on MW instead of doing my job

DRAKU WAS HERE SPRITEY IS A LOSER
#15
rtsmarty
firefox 47 is only 6 months old

like i'm sure all of these things were working 6 months ago for people using an up-to-date firefox

weird
#16
Spritanium
A lot of the codebase has changed in the past 6 months, though I'm not sure which of those changes apparently causes catastrophic failure in a slightly-old version of FF
[Image: O7N9eYD.png]
[Image: Q0L8Wm2.png]  <- Help me work on MW instead of doing my job

DRAKU WAS HERE SPRITEY IS A LOSER
#17
Draku
(Jan 7, 2017 at 12:32 PM)rtsmarty Wrote: firefox 47 is only 6 months old

like i'm sure all of these things were working 6 months ago for people using an up-to-date firefox

weird
that's why i didn't think it would fix it and didn't immediately mention it in my first post

its confusing
[Image: ynr38c.jpg]

Users browsing this thread:

Forum Jump:

";